- 三数中最大和最小
题目ID:1111必做题100分
最新提交:
Compile Error
0 分
历史最高:
Compile Error
0 分
时间限制: 1000ms
空间限制: 300000kB
题目描述
输入三个数,输出 最大数 和 最小数
输入格式:
输入一行,包含三个整数
a
,
b
,
c
a,b,c
输出格式:
输出两行,第一行输出最大数,第二行输出最小数。具体格式见样例输出。
样例输入:
1 2 3
样例输出:
The maximum number is : 3
The minimum number is : 1
约定:
1
<
a
,
b
,
c
<
1000000
1<=a,b,c<=1000000
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
⌄
⌄
⌄
#include <stdio.h>
int main()
{
int a,b,c,max,min;
printf(“input three int:”)
scanf(“%d,%d,%d”,&a,&b,&c);
if (a < b)
{
min = a;
min = b;
}
else
{
min = a;
min = b;
}
if(max < c)
max =c;
if(max < c)
max =c;
printf(“max: %d, min:%d”,max,min)
return 0;
}
自测样例
最新编译结果
#include <stdio.h>
int main()
{
int a,b,c,max,min;
printf(“input three int:”)
scanf(“%d,%d,%d”,&a,&b,&c);
if (a < b)
{
min = a;
min = b;
}
else
{
min = a;
min = b;
}
if(max < c)
max =c;
if(max < c)
max =c;
printf(“max: %d, min:%d”,max,min)
return 0;
}